Bejelentkezés
Felhasználónév:
Jelszó:
 
 
 
Regisztráció
Elfelejtett jelszó
Fórum témák
Fórum » DCC profiktól (nem csak) profiknak
DCC profiktól (nem csak) profiknak
Témaindító: Frankye, idő: Jan 23, 2013
Témakörök:

Lapozás       47/47
(#60457) diginewl válasza tibi hozzászólására (#60450) Válasz Okt 31, 2018
Megpróbálok segíteni.
A mozdonydekódert ugyanúgy kell programozni, mint a váltó dekódert.
Amíg programozol valamit, gondolom direkt CV rendszerben teszed, és nem POM módban vagy, akkor csak egy dolog lehet a programozó sínen/vezetéken. Ha esetleg eddog POM módban lett volna a központod programozása, akkor írd át direkt CV módra.

Cv1=5 ezt be tudok programozni a a mozdonynak?
(5-ös címre hallgasson) Ha igen, akkor ugyanígy arra a sínkimenetre kösd rá a váltódekódert. Ha a sima fucik, vagy Paco dekódert építettél, akkor a cv1=3 lesz a váltócíme. (ez nem mozdonycím, hanem váltócím Ezt te a programozásnál nem tudod eldönteni, hanem kiadod a parancsot, hogy cv1 értékét a céleszközön átírod x értékre, amit utána megadsz.)
Paco-nál
cv1 cím
cv3-6 a kitérés érték a közepétől. (mennyire menjen jobbra, balra)
Pl: CV3=4 akkor az első kimeneten levő szervó egy ici-picit fog jobbra/balra mozdulni, a két végállás között. ha 99értéket állítasz be, akkor majdnem 180 fokot mászik
cv35-38 sebessége a szervóknak.
Így már kicsit előrébb vagyunk?
(#60484) diginewl hozzászólása Válasz Nov 9, 2018
Tiszteletem!

Van egy jó és egy rossz hírem, az utóbbiban kérem a segítségeteket.
Jó hír, a minimaus - kijelzős - a PACO oldaláról szépen működik!!

A rossz: a TCO-xbus nem működik.
Állandóan világít a piros led, ami elméletileg azt jelentené, hogy nincs dcc-jel. Nincs kommunikáció, a másik led nem villog, ha az x-buson van forgalom. A panel nagyon viszi az áramot, melegszik a multiplexer chip, és a feszültségstabilizátor is.
A 29-es cím jó be van állítva.
"Elméletileg" nem rajzoltam el semmit már egyszer megint átnéztem. A pic-et is újra írtam, hátha az nem sikerült jól.

Van esetleg ötlet?
Köszönettel: Newl
(#60485) proba válasza diginewl hozzászólására (#60484) Válasz Nov 9, 2018
Első körben köss le mindent a multiplexer kimenetéről. Ha továbbra is melegszik, vedd ki. Ha továbbra sincs normális tápfeszültség akkor a stabilizátor is hibás lehet. ( természetesen ha lehet pic nélkül végezd ezeket a műveleteket, az esetleges hibás stabilizátor ne pusztítsa el azt is.)
(#60486) diginewl válasza proba hozzászólására (#60485) Válasz Nov 10, 2018
Köszi az ötleteket!

Nem volt semmi a multiplexer kimenetén, eleve így álltam neki.
Tettem be egy kisebb fesztstab ic-t azzal nem melegszik senki sem: 78L05
4,6V-ot mérek a fesztab ic után, ha benn van a multiplexer IC. Amúgy 4,9V-van rajta.
Nekem az fura, hogy nem villog a x-bus led.

Amit lehet kipróbáltam. Tettem bele másik PIC-et, másik busvezérlőt, ami a minimaus-ban működik.
Újra átnéztem a rajzot, nincs benne hiba.
Az egyetlen gyenge pont a multiplexer ic maradt. Ez már vagy 5 éve itt van nálam a 2 db, és szinte ingyen kaptam meg annó a boltban, annyira örült neki az eladó, hogy elviszem.
CD4515BCN van ráírva.
Ebből megpróbálok egyet venni valahogy újat. Más tippem nincs.

(#60487) Gabi válasza diginewl hozzászólására (#60486) Válasz Nov 10, 2018
Ne haragudj a buta feltételezésért, de nincs fordítva bedugva a multiplexer ic a helyére? Vagy nincs valahol valami panelzárlat?
(#60488) diginewl válasza diginewl hozzászólására (#60486) Válasz Nov 10, 2018
Bakker. Itt valami nagyon nem stimmel!!!
A PACO oldalán azt látom, hogy a CD chip
1: láb Vcc
23 láb: GND
PACO


A chip leírásánál meg ez van:
12: GND
24: VDD
CD 4515

Azért ezek elég nagy eltérések....
Most mit tegyek?

Hát bakker-bakker ezt nagyon megszívtam - már bocsánat. Mert én szépen nekiláttam a kapcsolási rajz alapján egy NYÁK-ot tervezni. De most nézem, hogy a PACO leírásánál levő áramkörben a 12-es láb a VSS, azaz a NYÁK rajz jó, de kapcsolási leírás NEM!!!

Most megint kezdhetem elölről...
(#60489) diginewl válasza diginewl hozzászólására (#60488) Válasz Nov 11, 2018
Kaptam egy ötletet - köszönöm!
Kipróbálom. A rajzon nincs jelölve, de be kell kötni a 12, és a 24-es lábat is a CD chipnél is.
Pont olyan, mint a max ic.nél. ott sincs jelölve a táp.
Jó lenne, ha nem kellene mindent átrajzolni.
(#60490) csttom válasza diginewl hozzászólására (#60488) Válasz Nov 11, 2018
Jó a Paco féle kapcsolási rajz, csak a cd4515-nél lehagyta a 12, 24 lábak (Vcc, Gnd) jelölését.
Ha a kapcsolási rajz alapján csináltad a nyák-ot, csak ezeket kell pótolnod, és működni fog.
(#60491) Frankye válasza diginewl hozzászólására (#60486) Válasz Nov 12, 2018
Azért az sem "rendes dolog", ha a 7805 kimenetén terhelés mellett csak 4,6 V van, míg terheletlenül 4,9. Ha mind a két sestben ugyan annyi lenne, akkor azt mondanám, hogy a mérés nem pontos, de ekkora kilengés nem volna szabad, hogy legyen.
Biztos, hogy a táp bemenete elbírja a terhelést? Gondolom, trafóról kapja a váltót, egyenirányítás, simítás, pufferelés után megy a 7805-re a táp. Nekem legalábbis gyanús a dolog.
(#60492) Lazsi válasza Frankye hozzászólására (#60491) Válasz Nov 12, 2018
Ezt egyszerűen meg lehet nézni: Meg kell mérni a 7805 bemenetén is a feszültséget terheléssel és anélkül.
(#60493) diginewl válasza diginewl hozzászólására (#60488) Válasz Nov 12, 2018
MŰKÖDIK!!! Köszönöm mindenkinek a segítséget!!!

A CD chip kapott GND-t, és 5V-ot. Innentől szépen megy minden. Váltók mozognak, led villan, amikor kimegy a parancs.
Ez van. A MAX 485-el is így jártam volna, ha a minimaus-t nem tervezem együtt a TCO-val. Ott láttam, hogy azt is be kell kötni tápra, és nullára is.
A CD 4515-nél az zavart meg, hogy a chip kapott nullát, és földet. Mint utóbb kiderült ez valami referencia dolog a chipnek, és nem a tápja.
Köszönöm!

ui: és a feszültség is helyreállt! 4,9V
Még engedett módosítani. Beteszem ide róluk a képet.
A nyákok saját munka.

WP_20181112_...jpg
 
(#60494) csíkosháTTú válasza diginewl hozzászólására (#60493) Válasz Nov 12, 2018


Sok "profi" - már, aki annak mondja, vagy gondolja magát - megirigyelhetné!
Szép munka, gratulálok Kolléga Úr!

(#60495) Frankye válasza diginewl hozzászólására (#60493) Válasz Nov 13, 2018
Csatlakozom Csíkos mesterhez, elismerésem! Profi kivitel.
(#60496) diginewl válasza csíkosháTTú hozzászólására (#60494) Válasz Nov 13, 2018
Ööö. Szerintem rosszul fogalmaztam, nem jár nekem az elismerés!
"A nyákok saját munka."
Úgy értettem, hogy fogtam a kapcs. rajzot eagle-ben megrajzoltam, ahogy nekem jobban tetszik. Ezért került minden máshova, mint az eredeti PACO nyákokon. Ezután elküldtem a gerbert Kínába. Innentől már nem az én érdemem a dolog
Ott 2 dollárért megcsinálták (készült még más is, arról majd később csicsergek, ha működik), kb 2000Ft-ért elküldték.
Annak nagyon örülök, hogy a minimaus "csont nélkül" azaz elsőre működik. A TCO-n már kell egy kis utómunka, de tulajdonképpen itt már nem tévesztettem a rajzon.

Elnézést, ha félreérthető voltam.
(#60498) csíkosháTTú válasza diginewl hozzászólására (#60496) Válasz Nov 15, 2018
A kínai csak azt tudja megcsinálni ám, amit Te megterveztél!
(#60509) tibi válasza diginewl hozzászólására (#60457) Válasz Nov 20, 2018
Háááát, nem nagyon sikerült előrébb haladni. Az én dekóderem csak 1 váltót mozgat, 1 utas. Minden váltónak van saját dekódere. Próbáltam ugy hogy beálitottam a dekódert kitérités programozásra ( a LED folytonosan világit), majd probáltam beirni CV3-ra, 4-re, 5-re és utána 6-ra is valami értéket 1 és 50 között (ezeket az értékeket adja meg a dekóder dokumentációja mint minimum és maximum). Eredmény? Semmi változás. Ugyanez történt mikor próbáltam a sebességnél beirni ( LED gyors villogás) a CV34-CV38 ra valami értéket 1 és 20 között. Mit csinálok rosszul? Gondolom hogy a CV alatti 4 jegyü szám a CV száma, utána ( Direct mod) alatt jön a CV értéke. a Pag /Rg a memória Page és Registry-t jelenti?

dcc1.jpg

dcc2.jpg
 
(#60510) diginewl válasza tibi hozzászólására (#60509) Válasz Nov 21, 2018
Ehhez a gen-li hez nem értek.
A programozást szerintem jól csinálod. Gyanítom, a mozdonydekóderek programozásával nincsen gond.
A váltók is úgy működnek...de.

Én nano-xs88-al és piros MM-el programozok direkt módban.
Amit én építettem paco dekódert abba nem tettem ledet, mert minek.
A paco szervó-nak 4 kimenete van. Visszafelé számolódnak azaz a 2-es kimenete (lába) a 4-es szervóé.

Amibe belehúzhatsz az a programozási cím.
Ha cv1=1 re programozod, akkor előfordulhat, hogy a 5-ös váltócímen fog megszólalni az első (azaz a pic 7-es lábán levő szervó), 8-as váltócímen meg a 2-es lábon levő szervó.
Valamiféle fura szabály szerint ezek a váltócímek számomra érthtetlenül, de működnek:

Általam létrehozott elmélet szerint mindig megtalálom a váltócímet:
ha 2-es-re programozom azaz cv1=2 akkor n*4+1, azaz 9-es címre fog hallgatni. Ha 3-as akkor 13-as címtől.
Azaz váltócím veszteség csak az első öt, mivel minden PIC-nek 4 kimenete van.
Próbáld meg így.

Valami nagy szaki egyszer már itt elmondta, hogy miért van ez így, valamit a roco egyszerűsített a lenz-hez képest, de a loconet is a lenz (xpress net) szerint kezeli a címet, azaz egy címen 4 váltó csücsül, kétféle állással. Na ezt én már nem tudtam követni
(#60511) csíkosháTTú válasza tibi hozzászólására (#60509) Válasz Nov 21, 2018
A CV3, CV4, és CV5 az tipikusan olyan CV regiszter, ami jellemzően a mozdonydekóderekben fordul elő.

Elsőként azt kellene ellenőrizni, hogy jó CV-ket próbálsz-e programozni?

A második ellenőrzést az diginewl kolléga írta le. A ROCO MultiMaus másképpen kezeli a váltócímeket, mint mindenki más. Alap, szabványos esetben egy váltódekódernek van egy címe, és ehhez tartozik négy, egymástól független váltó kezelése a megadott címen.
Na ehhez képest a ROCO (Fleischmann) MultiMaus egyszerű vezérlőjének csak két gombja van a váltók kezelésre, ergo egy váltócímhez csak egy váltó van, nem négy. Ebből adódóan a címek körül itt kavarodás van! Lásd még a CSM230RG váltódekóderem használati utasítását, ami Lenz rendszer szerint működik, így ROCO használata esetében nem lehet minden váltócímet beállítani.
(Előkészületben van egy váltódekóder a műhelyben, elsőre mágneses hajtóművekhez, ami kiküszöböli ezt a problémát. Ha Lenz-zel programozzuk be, akkor a Lenz szerinti, szabványos értékekre áll be. Ha MultiMaus-szal, akkor az első kimenete lesz pl. sz 1-es váltócím, a második a 2-es automatikusan, és így tovább. Meg ne kérdezzétek, hogy csinálja! A nagyobbik fiam írta a szoftvert Atmega vezérlőre.)
(#60513) diginewl válasza csíkosháTTú hozzászólására (#60511) Válasz Nov 22, 2018
Ehhez a váltócímhez egy adalék:
Ha piros MM-ről címzem meg az új szervóvezérlőmet, ha cv1=1-t írok bele, akkor az 5-ös címtől hallgat rá (1*4+1)
Ha a nyomógombról programozom fel akkor viszont tud 1-es címre is hallgatni az első cím. Paco unisemaf vezérlő van benne, és ebből pushbutton hex-et írtam bele.
érdekes.

Annak külön örülök, hogy a fiatalság nálatok besegít a vasútmodellbe!
(#60514) tibi válasza diginewl hozzászólására (#60513) Válasz Nov 22, 2018
Ezt a dekódert épitettem meg, ez nem tud két vagy négy szervót vezérelni, csak egy szervó kimenete van, és két visszajelzés meg sziv polarizáció a bistabil reléröl. És ez keseriti meg az életem, de vagy meg fog indulni vagy fog repülni, ez a három ahogy Hofi mondta, vagy mi nyerünk , vagy ők.

ServoPoint_s...gif
 
(#60515) diginewl válasza tibi hozzászólására (#60514) Válasz Nov 23, 2018
Ájájáj. Izé. Hát ez nem úgy programozódik, mint a többi....
Elolvastad?
To program a value, select that value as an address of accessories in the command station and give the
order to move it, ServoPoint stores that value and moves the servo with the new programmed values.
Ez nekem valami olyant jelent, hogy a buttont/bombot kell lenyomni 1 szer kétszer sokszor. Az szerint lép be valamelyik beállításba. Ez után a váltócím száma alapján, plusz egy kitérő/egyenes állítással írtad be az értéket.
Itt nincs CV lista, semmi!

Javaslom a pofonegyszerűbb 4 szervósat megcsinálni. Azt CV-kel kell progizni.
4 szervós.
Itt a honlapon egyik fórumtárs írt rá egy nem táncoló HEX-et.

De van egy olyan ami két szervót is vezérel+2 relét.
Szintén a paco oldalán. De előbb a fenti 4 szervós lenne az igazi próbának.
(#60554) maya711 hozzászólása Válasz Dec 9, 2018
Elkészült a már régebben(2016július) említett ál-Littfinsky féle hurokmodulnak a mechanika nélküli(vagyis relé-mentes) változata 8db opto-relével. Bár ezek az alkatrészek jelentősen többe kerülnek mint a 3db relé(idehaza), azért gondolat-ébresztőnek mellékelem a kapcsolást. Meg a 3-relés kapcsolást is. Talán túl bonyolultnak tűnik, de nyugodtan elhagyhatók belőle a D5...D8 diódák valamint az OK1...OK5 és az ezekhez kapcsolódó alkatrészek, amennyiben lemondunk a hurok bevezető váltójának automatikus működtetéséről és a hurok foglaltságának jelzéséről.
Ha valakit a működtető program is érdekel, írjon erre a címre: ***@***.***. Küldeni fogom a programot, mint eddig is: térítésmentesen.

HUROKMODUL_3...pdf

HUROKMODUL_8...pdf
 
(#60555) Lazsi válasza maya711 hozzászólására (#60554) Válasz Dec 9, 2018
Szerintem, nem kellene kiírnod az e-mail címedet... Az adatlapodon úgyis ott van, vagyis onnan bárki könnyen megszerezheti... Szerintem...
(#60558) Frankye moderátori válasza Lazsi hozzászólására (#60555) Válasz Dec 11, 2018
Bizony, hogy nem! A spammerbotok ezekre vadásznak, ne etessük őket! El is távolítottam.
(#60568) diginewl hozzászólása Válasz Dec 14, 2018
Tiszteletem!
Van egy izgalmas kérdésem, hátha valaki tudja rá a választ:
a PACO unisemaf vezérlőjénél a PIC 12-es lábán van egy LED.
Eddig nekem nem sikerült rávennem, hogy az felvillanjon. Se programozáskor, se a nyomógomb megnyomásakor. Semikor...
(Micsoda problémák, mi? )
unisemaf
Nem értem mi célt szolgálhat.

Számomra nagy előrelépés, hogy sikerült tesztelnem a nyomógombos hex változatát ennek a kapcsolásnak, és az is szépen működik! Felhasználóbarát, mert egy váltóállítás paranccsal már fel is van címezve a PIC, az új váltócímre. Csendben jegyzem meg, csak alacsony váltócímen próbáltam 100 felett nem. Ott nem tudom mit csinál, viszont nem szándékozom száznál több váltót kezelni
(#60573) maya711 válasza maya711 hozzászólására (#60554) Válasz Dec 18, 2018
Rájöttem hogy ez még szükséges lehet az értelmezéshez:

hurokmodul_v...jpg
 
(#60574) diginewl válasza diginewl hozzászólására (#60568) Válasz Dec 18, 2018
Kaptam választ a kérdésemre!
Köszönöm!
(#60577) diginewl válasza diginewl hozzászólására (#60574) Válasz Dec 21, 2018
Közben valami csoda folytán elkezdett villogni az a bizonyos LED!
Hogy eddig hogyan nem vettem észre? Biztosan villogott, csak talán pont akkor nem néztem oda??? (röviden villog)
Programozás közben aktív a LED!
A másik funkcióját is kipróbálom.
(#60608) MetalHunterR hozzászólása Válasz Dec 27, 2018
Sziasztok, segítséget szeretnék kérni. Dobtam össze magamnak egy DCC++ központot, ami nagyon remekül működik azt leszámítva hogy nem találja meg a dekódereket. Ha debug módba kapcsolom, akkor az Arduino és a motor shield is villog ahogy annak kell. Vettem egy vadonat új Lenz Standard + V2-es dekódert, de nem ismeri fel a JMRI.

Mozgatja a motort nagyon kicsit, de világítást nem villogtatja, mindegy hogy dugom be. "No roster entry found" ot dob vissza. Próbáltam kézileg "New Loco" listából de azzal se. 12V 2A táp van rajta, VIN a shielden elvágva. Tudna valaki esetleg segíteni?
Lapozás       47/47
Frissek
  2019. Jan, 22. Kedd
14:08:41
  Jelenleg 19 fő olvassa az oldalt
Hirdetés